Browser Compatibility

LOGIN



99.3% of Internet users inherently trust Instant SSL Certificates – Equivalent to VeriSign and Thawte!

Browser Compatibility:

  • Internet Explorer 5.01 and above
  • Netscape 4.77 and above
  • Firefox 0.1 and above
  • Mozilla 0.6 and above
  • AOL 5 and above
  • Opera 8 and above
  • Safari 1.2 and above

Tip:- For the latest figures on browser adoption please look at OneStat here

Our Root is trusted by over 99.3% of all current browsers comprising all Internet Explorer 5.01 and above, Netscape 4.77 and above, AOL 5 and above and Opera 8 and above.